1149 posts
  • Elite Author
  • Author Level 7
  • Weekly Top Seller
  • Top Monthly Author
+10 more
survivor
says

Hey to all PHP and Wordpress proffesionals.

I need your help about setting up a server.

I have my own server with PHP version 5.2.13. Now I’ll be transferring all my sites into new server. I’m total noob about servers so I’m not setting it on my own, but the person who is setting it for me asked if He can install new 5.3.x PHP into my new server.

So here is the question.

Will the newer PHP version affect somehow WP sites? I’m running around 40 sites all made in WP. Some sites are on older WP versions.

Thank You

973 posts
  • Affiliate Level 2
  • Author Level 4
  • Beta Tester
  • Collector Level 4
+6 more
aaranmcguire
says

It should not cause any problems that i know of.

737 posts
  • Affiliate Level 7
  • Author Level 8
  • Collector Level 3
  • Top Monthly Author
+9 more
mordauk
says

The older versions of PHP tend to cause more problems.

3042 posts
  • Author Level 1
  • Collector Level 3
  • Exclusive Author
  • Beta Tester
+2 more
TNL3542
says

The older versions of PHP tend to cause more problems.

it might and again it might not.. just gotta use your own and his judgement.. who i host with its all up to date

310 posts mekshq.com
  • Elite Author
  • Trendsetter
  • Weekly Top Seller
  • Featured Author
+8 more
meks
says

Just backup all websites first, just to be sure…

2 posts
  • 3 Years of Membership
  • Author Level 3
  • Exclusive Author
  • United Kingdom
kodefoundry
says

It’s absolutely impossible for anyone here to tell if your sites will break. We don’t have any knowledge of the code that is used by the sites themes and/or installed plugins.

The only way to tell for sure is creating a test environment first and going through them one by one testing each of the sites functionalities.

Don’t just take a gamble, that would be insane.

Kevin

1149 posts
  • Elite Author
  • Author Level 7
  • Weekly Top Seller
  • Top Monthly Author
+10 more
survivor
says

Ok, thanks for all your comments, I told him to use the same PHP version as on the older server, so everything should be same.

by
by
by
by
by
by