226 posts
  • Has referred 100+ members
  • Has sold $40,000+ on Envato Market
  • Has been a beta tester for an Envato feature
  • Had an item featured in an Envato Bundle
+4 more
h3design says

I also have this issue since today: can´t open any new tabs by clicking links or thumbs with my mousewheel…
very strange and annoying :(

2217 posts
  • Has been part of the Envato Community for over 5 years
  • Has referred 1+ members
  • Has sold $40,000+ on Envato Market
  • Interviewed on an Envato blog
+6 more
urbazon says

I also have this issue since today: can´t open any new tabs by clicking links or thumbs with my mousewheel…
very strange and annoying :(

Marketplaces are falling apart and we have no official answer for two days! Argh! :(

846 posts
  • Has referred 100+ members
  • Has sold $10,000+ on Envato Market
  • Has been a beta tester for an Envato feature
  • Has collected 100+ items on Envato Market
+4 more
kaixer says


I also have this issue since today: can´t open any new tabs by clicking links or thumbs with my mousewheel…
very strange and annoying :(
Marketplaces are falling apart and we have no official answer for two days! Argh! :(

they are calculating their bundle sales.

:grin:

315 posts
  • Has been part of the Envato Community for over 4 years
  • Elite Author: Sold more than $75,000 on Envato Market
  • Made it to the Authors' Hall of Fame
  • Had an item featured on Envato Market
+6 more
bitpub says

I have the issue too. Please fix this as it is really screwing up my workflow.

243 posts
  • Located in United States
  • Won a Most Wanted contest
  • Won a competition
  • Had an item featured on Envato Market
+5 more
deiby says

Please fix this!

5777 posts
  • Member of the Envato Team
  • Has been part of the Envato Community for over 4 years
  • Located in Canada
  • Joined us in one of our Envato Live Events
+13 more
KingDog Envato team says

Marketplaces are falling apart and we have no official answer for two days! Argh! :(

I responded less than 24 hours ago that the Devs have been informed :) Now they’re working on a fix. Thanks!

2217 posts
  • Has been part of the Envato Community for over 5 years
  • Has referred 1+ members
  • Has sold $40,000+ on Envato Market
  • Interviewed on an Envato blog
+6 more
urbazon says


Marketplaces are falling apart and we have no official answer for two days! Argh! :(
I responded less than 24 hours ago that the Devs have been informed :) Now they’re working on a fix. Thanks!

I’m sorry, I thought you were referring to the thumbnail layout problems. Thank you. Hopefully they’ll fix it soon.

This middle-click (and ctrl+click) issue is really annoying and as bitpub pointed out above, it interferes with my workflow as well.

808 posts
  • Has sold $10,000+ on Envato Market
  • Pulled off some great moustache to raise money or awareness for Movember Australia
  • Helped several times protecting Envato Market against copyright violations
  • Won a Most Wanted contest
+7 more
EladChai says

and I thought only I have this strange problem (: hope it will be fixed soon.

7792 posts
  • Has been part of the Envato Community for over 5 years
  • Has sold $40,000+ on Envato Market
  • Sells items exclusively on Envato Market
  • Has referred 10+ members
+4 more
doru says

any javascript guru can look at the code and see what blocks the middle click? I’ve tried to look with firebug but no luck.

1329 posts
  • Has been part of the Envato Community for over 2 years
  • Has referred 200+ members
  • Has sold $125,000+ on Envato Market
  • Has been a beta tester for an Envato feature
+8 more
Pricop says

I don’t know if I’m alone in this, but since this morning (yup, it’s morning here :) ) I’ve noticed strange behavior in Firefox, and it happens only on Envato marketplaces: middle-click on mouse won’t open link in new tab. Nothing happens at all. It works on all other websites. And it works well in Chrome, even on Envato websites. Moreover, I haven’t noticed Firefox update, so it’s weird as I don’t know what could’ve caused it during the night. Have devs changed something?

I’m always using the middle-button of my mouse to open links in new tab, it would be a disaster if it wouldn’t work =) I hope they fix this.

by
by
by
by
by
by