341 posts Andre28 - Envato Elite Author
  • Elite Author
  • Exclusive Author
  • 4 Years of Membership
  • Italy
+7 more
andre28
says

When someone write to me though my profile page, the email always go under the “spam” section on my provider email… Is there anything i can do to fix this? I always click on the “this message is safe” button, but nothing change… Any suggestions?? Thank you

17 posts
  • 4 Years of Membership
  • Affiliate Level 1
  • Author Level 5
  • Collector Level 3
+4 more
beatlover
says

Check your spam settings in your email account… You can add filter eq. if message subject contains [GraphicRiver] mark this as not spam :)

1257 posts
  • Affiliate Level 2
  • Author Level 6
  • Collector Level 4
  • Weekly Top Seller
+3 more
Demorfoza
says

Are you using a web based mail, or software to check your mailbox?

341 posts Andre28 - Envato Elite Author
  • Elite Author
  • Exclusive Author
  • 4 Years of Membership
  • Italy
+7 more
andre28
says

i’m using windows live mail, with my account on hotmail… still i haven’t solved this problem..

11 posts
  • 4 Years of Membership
  • Collector Level 2
  • United States
spoocobra
says

I’d switch that to gmail and do like beatlover says and add filters.

by
by
by
by
by
by