2054 posts
  • Has referred 50+ members
  • Has sold $750,000+ on Envato Market
  • Has collected 10+ items on Envato Market
  • Elite Author: Sold more than $75,000 on Envato Market
+11 more
bitfade
says

me trying to find meaningful variable/methods names

685 posts
  • Has referred 50+ members
  • Has sold $40,000+ on Envato Market
  • Has been a beta tester for an Envato feature
  • Has collected 100+ items on Envato Market
+5 more
UBLThemes
says

This post was not mention to be just about the variables it was also about commenting lol

5492 posts
  • Has been part of the Envato Community for over 5 years
  • Has referred 1+ members
  • Located in Australia
  • Has sold $1,000+ on Envato Market
+5 more
Australia
says

This post was not mention to be just about the variables it was also about commenting lol

We know ;) and yup u have a point, but var naming isnt standardised.

P.s. wasnt trying to be professional, but $i count within array is normal

685 posts
  • Has referred 50+ members
  • Has sold $40,000+ on Envato Market
  • Has been a beta tester for an Envato feature
  • Has collected 100+ items on Envato Market
+5 more
UBLThemes
says
About a week back I did a Wordpress theme from here and all the functions and variables were like:
function xxxxx(){
global $xcv;
 $xyz = $xcv + 3;
}

And with no commenting at all

776 posts
  • Had an item that was trending
  • Has been part of the Envato Community for over 3 years
  • Has sold $10,000+ on Envato Market
  • Sells items exclusively on Envato Market
+2 more
Typps
says

Perhaps clients that purchased an item, in this case a WordPress plugin need to contact the original author and request the extra feature desired. This provides extra revenue to the author and allows the client easy future upgrade paths, in case an update is available.

IMHO , apart from using standard coding practices, in case of plugins, one is not required to document the code nor the API as this is not what we’re ultimately selling, but rather a product to be used by the end user, where customization’s through code defeats the purpose of the plugin.

The example you’ve made of obfuscated variable names is not a standard coding practice and is likely going to bite the author in the rear sooner than later. But until they learn at their own expense there is not much you can do about it, i suppose ^^

2276 posts
  • Became a Top 20 Author of the Month
  • Had an item that became a weekly top seller
  • Created a helpful tool/app using the Envato API
  • Created a helpful tool/app for Envato Market users
+15 more
revaxarts
says

About a week back I did a Wordpress theme from here and all the functions and variables were like:
function xxxxx(){
global $xcv;
 $xyz = $xcv + 3;
}
And with no commenting at all
function xxxxxx() is bad and should get prefixed if someone else use that generic name function mycoolplugin_xxxxxx()
1633 posts fueledweb.com
  • Has referred 10+ members
  • Has sold $125,000+ on Envato Market
  • Has collected 10+ items on Envato Market
  • Became a Top 20 Author of the Month
+8 more
RimmonTrieu
says

You are talking about Coding Standard and I agree there must be some sort of regulation about that. Careless variable naming just shows how amateur the coders are.

Also I believe code commenting is a must for every file uploaded to marketplace, at least at AD we have done that for years.

141 posts
  • Had an item that became a weekly top seller
  • Sells items exclusively on Envato Market
  • Has sold $1,000+ on Envato Market
  • Has been part of the Envato Community for over 7 years
+7 more
ram64
says

Well I think that if we speak of JavaScript it’s all about file size and that’s why there are short, irrelevant function or variable names and no comments. But this should be a compressed version of the file. IMO every JavaScript file should be in two versions: compressed and uncompressed, where the uncompressed version would be abundent in details (at least for codecanyon). But when it comes to other programming languages where the code size does not matter then I agree that all functions/methods/variables need to have meaningful names and apropriate comments.

685 posts
  • Has referred 50+ members
  • Has sold $40,000+ on Envato Market
  • Has been a beta tester for an Envato feature
  • Has collected 100+ items on Envato Market
+5 more
UBLThemes
says

Perhaps clients that purchased an item, in this case a WordPress plugin need to contact the original author and request the extra feature desired. This provides extra revenue to the author and allows the client easy future upgrade paths, in case an update is available.

IMHO , apart from using standard coding practices, in case of plugins, one is not required to document the code nor the API as this is not what we’re ultimately selling, but rather a product to be used by the end user, where customization’s through code defeats the purpose of the plugin.

The example you’ve made of obfuscated variable names is not a standard coding practice and is likely going to bite the author in the rear sooner than later. But until they learn at their own expense there is not much you can do about it, i suppose ^^

I agree it’s not required and it should be.

I was always told to always code in mind that another developer needs to read your code so make it neat and meaningful.

In my opinion coding this way neither benefitting the person coding it or the poor developer who has to read it in the future.

685 posts
  • Has referred 50+ members
  • Has sold $40,000+ on Envato Market
  • Has been a beta tester for an Envato feature
  • Has collected 100+ items on Envato Market
+5 more
UBLThemes
says

You are talking about Coding Standard and I agree there must be some sort of regulation about that. Careless variable naming just shows how amateur the coders are. Also I believe code commenting is a must for every file uploaded to marketplace, at least at AD we have done that for years.

+1

by
by
by
by
by
by