53 posts Master of the Internets
  • Australia
  • Bought between 10 and 49 items
  • Exclusive Author
  • Grew a moustache for the Envato Movember competition
  • Has been a member for 3-4 years
  • Referred between 1 and 9 users
chendo says

Hey all,

We’ve updated the item upload forms (both new item upload and item update upload) as well as portfolio upload form to be asynchronous. Previously, if one were to upload an item or portfolio with large (300MB and up) attachments, you would sometimes get the dreaded “405 Method Not Allowed” error. This update pushes the processing for the update into the background, thus prevents that error from occurring.

Please let us know if you still get the “405 Method Not Allowed” issue.

2954 posts
  • Australia
  • Community Moderator
  • Elite Author
  • Author had a Free File of the Month
  • Most Wanted Bounty Winner
  • Author had a File in an Envato Bundle
  • Has been a member for 5-6 years
  • Contributed a Blog Post
  • Repeatedly Helped protect Envato Marketplaces against copyright violations
+10 more
dtbaker Volunteer moderator says

:)

Sweet. Yep that Method Not Allowed from Ubuntu was a common sight, haven’t seen it recently though, hopefully it’s gone for good!

1402 posts
  • Author had a File in a Mini Bundle
  • Has been a member for 4-5 years
  • Sold between 1 000 and 5 000 dollars
  • Exclusive Author
  • Bought between 50 and 99 items
  • Referred between 10 and 49 users
  • United States
WebSmacker says

These small improvements are adding up. Great job dev team!

8190 posts Community Moderator
  • Attended a Community Meetup
  • Community Moderator
  • Has been a member for 6-7 years
  • United Kingdom
  • Contributed a Tutorial to a Tuts+ Site
  • Won a Competition
  • Contributed a Blog Post
  • Beta Tester
  • Bought between 50 and 99 items
+4 more
MSFX Volunteer moderator says

:)

Sweet. Yep that Method Not Allowed from Ubuntu was a common sight, haven’t seen it recently though, hopefully it’s gone for good!

lol! :D

2086 posts
  • Author had a File in an Envato Bundle
  • Contributed a Blog Post
  • Exclusive Author
  • Has been a member for 4-5 years
  • Interviewed on the Envato Notes blog
  • Most Wanted Bounty Winner
  • Referred between 1 and 9 users
  • Serbia
+1 more
urbazon says

I’ve noticed some changes a few days ago. I thought I should mention this, as I think it might be related: a few days ago I had a file soft-rejected because of preview image. I fixed it and uploaded (via ftp) and when I went to the upload form via Firefox to update my hidden item, after pressing “Submit” button, I was redirected to a blank page and although update went through, it didn’t contain my updated file. Later I tried it via Chrome and it worked well.

53 posts Master of the Internets
  • Australia
  • Bought between 10 and 49 items
  • Exclusive Author
  • Grew a moustache for the Envato Movember competition
  • Has been a member for 3-4 years
  • Referred between 1 and 9 users
chendo says

I’ve noticed some changes a few days ago. I thought I should mention this, as I think it might be related: a few days ago I had a file soft-rejected because of preview image. I fixed it and uploaded (via ftp) and when I went to the upload form via Firefox to update my hidden item, after pressing “Submit” button, I was redirected to a blank page and although update went through, it didn’t contain my updated file. Later I tried it via Chrome and it worked well.

When exactly? We turned it on for everyone about 12pm on Friday (GMT+10) after a day of rolling it out to ~10% of authors. We had some teething issues initially but ironed them out by around 2pm.

2086 posts
  • Author had a File in an Envato Bundle
  • Contributed a Blog Post
  • Exclusive Author
  • Has been a member for 4-5 years
  • Interviewed on the Envato Notes blog
  • Most Wanted Bounty Winner
  • Referred between 1 and 9 users
  • Serbia
+1 more
urbazon says


I’ve noticed some changes a few days ago. I thought I should mention this, as I think it might be related: a few days ago I had a file soft-rejected because of preview image. I fixed it and uploaded (via ftp) and when I went to the upload form via Firefox to update my hidden item, after pressing “Submit” button, I was redirected to a blank page and although update went through, it didn’t contain my updated file. Later I tried it via Chrome and it worked well.
When exactly? We turned it on for everyone about 12pm on Friday (GMT+10) after a day of rolling it out to ~10% of authors. We had some teething issues initially but ironed them out by around 2pm.

Hi, Chendo. Sorry for late response. I just checked my emails. It happened on 3rd May, a few minutes after 3:20 PM. And then again a few minutes after at 3:40 PM (yes, it took me two attempts to switch from Firefox to Chrome and succeed :) ). Timezone is UTC+1

I can also probably find the URL that was shown in Firefox on the blank page, if you need that info as well? Something with suffix “job_id=....”, something like that.

53 posts Master of the Internets
  • Australia
  • Bought between 10 and 49 items
  • Exclusive Author
  • Grew a moustache for the Envato Movember competition
  • Has been a member for 3-4 years
  • Referred between 1 and 9 users
chendo says



I’ve noticed some changes a few days ago. I thought I should mention this, as I think it might be related: a few days ago I had a file soft-rejected because of preview image. I fixed it and uploaded (via ftp) and when I went to the upload form via Firefox to update my hidden item, after pressing “Submit” button, I was redirected to a blank page and although update went through, it didn’t contain my updated file. Later I tried it via Chrome and it worked well.
When exactly? We turned it on for everyone about 12pm on Friday (GMT+10) after a day of rolling it out to ~10% of authors. We had some teething issues initially but ironed them out by around 2pm.

Hi, Chendo. Sorry for late response. I just checked my emails. It happened on 3rd May, a few minutes after 3:20 PM. And then again a few minutes after at 3:40 PM (yes, it took me two attempts to switch from Firefox to Chrome and succeed :) ). Timezone is UTC+1

I can also probably find the URL that was shown in Firefox on the blank page, if you need that info as well? Something with suffix “job_id=....”, something like that.

The job_id would make my life a lot easier if you have that :)

2086 posts
  • Author had a File in an Envato Bundle
  • Contributed a Blog Post
  • Exclusive Author
  • Has been a member for 4-5 years
  • Interviewed on the Envato Notes blog
  • Most Wanted Bounty Winner
  • Referred between 1 and 9 users
  • Serbia
+1 more
urbazon says




I’ve noticed some changes a few days ago. I thought I should mention this, as I think it might be related: a few days ago I had a file soft-rejected because of preview image. I fixed it and uploaded (via ftp) and when I went to the upload form via Firefox to update my hidden item, after pressing “Submit” button, I was redirected to a blank page and although update went through, it didn’t contain my updated file. Later I tried it via Chrome and it worked well.
When exactly? We turned it on for everyone about 12pm on Friday (GMT+10) after a day of rolling it out to ~10% of authors. We had some teething issues initially but ironed them out by around 2pm.

Hi, Chendo. Sorry for late response. I just checked my emails. It happened on 3rd May, a few minutes after 3:20 PM. And then again a few minutes after at 3:40 PM (yes, it took me two attempts to switch from Firefox to Chrome and succeed :) ). Timezone is UTC+1

I can also probably find the URL that was shown in Firefox on the blank page, if you need that info as well? Something with suffix “job_id=....”, something like that.
The job_id would make my life a lot easier if you have that :)

Found it in item’s history :)
This is the full url: http://videohive.net/item/sunset-with-tropical-clouds-time-lapse/4616828/item_updates/resubmit?job_id=c19de158-1660-4064-adfa-f32b154f2287 that was kept in Firefox address bar after clicking the “Submit” button upon item update and being forwarded to a blank page. Just to mention it once again: this happened twice in Firefox, and then third time I’ve used Chrome and it worked as it is supposed to, update went through. (this particular url is after the second attempt in FF)

2086 posts
  • Author had a File in an Envato Bundle
  • Contributed a Blog Post
  • Exclusive Author
  • Has been a member for 4-5 years
  • Interviewed on the Envato Notes blog
  • Most Wanted Bounty Winner
  • Referred between 1 and 9 users
  • Serbia
+1 more
urbazon says

@chendo: any chance this change is affecting the way portfolio pages are loaded? Since a few days ago (I don’t know when, exactly) I’ve noticed significantly slower loading of my own portfolio pages (all marketplaces), in both Chrome and Firefox, but ONLY when I’m logged in. When I’m logged out, it works instantly. (I tried clearing cache and cookies but nothing changed)

by
by
by
by
by
by