643 posts
  • Has referred 50+ members
  • Has sold $40,000+ on Envato Market
  • Has been a beta tester for an Envato feature
  • Has collected 100+ items on Envato Market
+5 more
UBLThemes says

Hi I just sat with a client and signed up with him using our referral link

He the went on to buy the salient theme.

I then log back into my account and no referral has been given

My question is….

Is the system delayed?

If so why? It just seems a little suss

1838 posts Don't Worry, Be Happy
  • Sells items exclusively on Envato Market
  • Elite Author: Sold more than $75,000 on Envato Market
  • Located in United States
  • Made it to the Authors' Hall of Fame
+8 more
FinalDestiny says

He probably visited the ThemeForest website before and had a cookie placed on his computer already.

2081 posts
  • Made it to the Authors' Hall of Fame
  • Had an item featured on Envato Market
  • Provided great feedback to improve the user experience on Envato Market
  • Interviewed on an Envato blog
+9 more
revaxarts says

It’s probably because your client visit the marketplace before so your referral doesn’t count.

You should tell him to delete all cookies from the marketplace and visit the site afterwards.

Edit: beat by Final :D

1055 posts
  • Has sold $5,000+ on Envato Market
  • Located in United Kingdom
  • Has been a beta tester for an Envato feature
  • Helped several times protecting Envato Market against copyright violations
+5 more
Alexlasek says

Probably he visited one of envato market earlier so your reference doesn’t work ;/

You are not alone, it happens all the time. Next time ask your client to clear the cache in a browser before buying anything.

cheers

643 posts
  • Has referred 50+ members
  • Has sold $40,000+ on Envato Market
  • Has been a beta tester for an Envato feature
  • Has collected 100+ items on Envato Market
+5 more
UBLThemes says

He probably visited the ThemeForest website before and had a cookie placed on his computer already.

It was my computer and I cleared all caches just to make sure

643 posts
  • Has referred 50+ members
  • Has sold $40,000+ on Envato Market
  • Has been a beta tester for an Envato feature
  • Has collected 100+ items on Envato Market
+5 more
UBLThemes says

It’s probably because your client visit the marketplace before so your referral doesn’t count.

You should tell him to delete all cookies from the marketplace and visit the site afterwards.

Edit: beat by Final :D

It was from my iMac and all cookies were cleared

643 posts
  • Has referred 50+ members
  • Has sold $40,000+ on Envato Market
  • Has been a beta tester for an Envato feature
  • Has collected 100+ items on Envato Market
+5 more
UBLThemes says

Probably he visited one of envato market earlier so your reference doesn’t work ;/

You are not alone, it happens all the time. Next time ask your client to clear the cache in a browser before buying anything.

cheers

It’s not the cookies because I did it from my mac and I cleared all caches for this reason

1745 posts
  • Has referred 1+ members
  • Has sold $10,000+ on Envato Market
  • Has been a beta tester for an Envato feature
  • Has collected 1+ items on Envato Market
+2 more
gbs says

If you were successful with this method some times before then this time there should be a mistake somewhere, mostly in the cache, cookies etc.,. We have no control of that either. Only Envato knows what already happened.

2081 posts
  • Made it to the Authors' Hall of Fame
  • Had an item featured on Envato Market
  • Provided great feedback to improve the user experience on Envato Market
  • Interviewed on an Envato blog
+9 more
revaxarts says

If it’s a valid referrer the URL gets a “clickthrough_id” query var. This indicates a successful referral

643 posts
  • Has referred 50+ members
  • Has sold $40,000+ on Envato Market
  • Has been a beta tester for an Envato feature
  • Has collected 100+ items on Envato Market
+5 more
UBLThemes says

If it’s a valid referrer the URL gets a “clickthrough_id” query var. This indicates a successful referral

To tell you the truth this I did not know so did not look for it but if the the had the ?ref=UBL it should work unless its a delayed response to make sure not charged back or there is a bug

Helpful Information

  • Please read our community guidelines. Self promotion and discussion of piracy is not allowed.
  • Open a support ticket if you would like specific help with your account, deposits or purchases.
  • Item Support by authors is optional and may vary. Please see the Support tab on each item page.

Most of all, enjoy your time here. Thank you for being a valued Envato community member.

Post Reply

Format your entry with some basic HTML. Read the Full Details, or here is a refresher:

<strong></strong> to make things bold
<em></em> to emphasize
<ul><li> or <ol><li> to make lists
<h3> or <h4> to make headings
<pre></pre> for code blocks
<code></code> for a few words of code
<a></a> for links
<img> to paste in an image (it'll need to be hosted somewhere else though)
<blockquote></blockquote> to quote somebody

:grin: :shocked: :cry: Complete List of Smiley Codes

by
by
by
by
by
by