689 posts
  • Affiliate Level 3
  • Author Level 6
  • Beta Tester
  • Collector Level 4
+5 more
UBLThemes
says

Hi I just sat with a client and signed up with him using our referral link

He the went on to buy the salient theme.

I then log back into my account and no referral has been given

My question is….

Is the system delayed?

If so why? It just seems a little suss

2065 posts Don't Worry, Be Happy
  • Trendsetter
  • Weekly Top Seller
  • Exclusive Author
  • Elite Author
+9 more
FinalDestiny
says

He probably visited the ThemeForest website before and had a cookie placed on his computer already.

2280 posts
  • Top Monthly Author
  • Weekly Top Seller
  • Community Superstar
  • Industrious API Inventor
+15 more
revaxarts
says

It’s probably because your client visit the marketplace before so your referral doesn’t count.

You should tell him to delete all cookies from the marketplace and visit the site afterwards.

Edit: beat by Final :D

1127 posts
  • United Kingdom
  • Author Level 5
  • Affiliate Level 3
  • Collector Level 1
+5 more
Alexlasek
says

Probably he visited one of envato market earlier so your reference doesn’t work ;/

You are not alone, it happens all the time. Next time ask your client to clear the cache in a browser before buying anything.

cheers

689 posts
  • Affiliate Level 3
  • Author Level 6
  • Beta Tester
  • Collector Level 4
+5 more
UBLThemes
says

He probably visited the ThemeForest website before and had a cookie placed on his computer already.

It was my computer and I cleared all caches just to make sure

689 posts
  • Affiliate Level 3
  • Author Level 6
  • Beta Tester
  • Collector Level 4
+5 more
UBLThemes
says

It’s probably because your client visit the marketplace before so your referral doesn’t count.

You should tell him to delete all cookies from the marketplace and visit the site afterwards.

Edit: beat by Final :D

It was from my iMac and all cookies were cleared

689 posts
  • Affiliate Level 3
  • Author Level 6
  • Beta Tester
  • Collector Level 4
+5 more
UBLThemes
says

Probably he visited one of envato market earlier so your reference doesn’t work ;/

You are not alone, it happens all the time. Next time ask your client to clear the cache in a browser before buying anything.

cheers

It’s not the cookies because I did it from my mac and I cleared all caches for this reason

1766 posts
  • Affiliate Level 1
  • Author Level 5
  • Beta Tester
  • Collector Level 1
+2 more
gbs
says

If you were successful with this method some times before then this time there should be a mistake somewhere, mostly in the cache, cookies etc.,. We have no control of that either. Only Envato knows what already happened.

2280 posts
  • Top Monthly Author
  • Weekly Top Seller
  • Community Superstar
  • Industrious API Inventor
+15 more
revaxarts
says

If it’s a valid referrer the URL gets a “clickthrough_id” query var. This indicates a successful referral

689 posts
  • Affiliate Level 3
  • Author Level 6
  • Beta Tester
  • Collector Level 4
+5 more
UBLThemes
says

If it’s a valid referrer the URL gets a “clickthrough_id” query var. This indicates a successful referral

To tell you the truth this I did not know so did not look for it but if the the had the ?ref=UBL it should work unless its a delayed response to make sure not charged back or there is a bug

by
by
by
by
by
by