6763 posts
  • Italy
  • Sold between 10 000 and 50 000 dollars
  • Has been a member for 4-5 years
  • Microlancer Beta Tester
  • Beta Tester
  • Repeatedly Helped protect Envato Marketplaces against copyright violations
  • Exclusive Author
  • Author had a Free File of the Month
  • Bought between 10 and 49 items
+1 more
doru says

If you search the forum using the box on the right while you are viewing a thread you will get “No Results Were Found”. If you click the “Search Again” button on that page then you will get the results.

If you use the box from the main page of the forum, where the list of threads are listed :) , the search box works.

I think the problem is that for some reason the search box pass the id of the thread from where you made the search. I don’t understand why the search needs the id but anyway this is the link generated by the search box from within a forum thread:

http://themeforest.net/old_search?utf8=%E2%9C%93&term=collins&type=forums&type_id=thread%3A77051

and this is the link generated by the search box from the main page of the forum:

http://themeforest.net/old_search?utf8=%E2%9C%93&term=collins&type=forums&type_id=
446 posts
  • Bought between 1 and 9 items
  • Exclusive Author
  • Has been a member for 2-3 years
  • Referred between 10 and 49 users
  • Sold between 10 000 and 50 000 dollars
D_Cooper says

As I understand in first case it search in the Forum Area (Notices, All Marcetplaces, Item Discussions etc) where your thread is located.
If there is no result in this area you gets empty search results page (your first link)
Then you click ‘Search again” and it search through the selected area in “Search In” drop-down

6763 posts
  • Italy
  • Sold between 10 000 and 50 000 dollars
  • Has been a member for 4-5 years
  • Microlancer Beta Tester
  • Beta Tester
  • Repeatedly Helped protect Envato Marketplaces against copyright violations
  • Exclusive Author
  • Author had a Free File of the Month
  • Bought between 10 and 49 items
+1 more
doru says

verified now. It appears it will search first the thread you are reading at that moment. if it finds some results it will return the post where that term is mentioned, if not you get no results.

So is not a bug but probably work in progress. Maybe the search box will get pertinent description “search within the thread” later on.

8110 posts Community Moderator
  • Attended a Community Meetup
  • Community Moderator
  • Has been a member for 6-7 years
  • United Kingdom
  • Contributed a Tutorial to a Tuts+ Site
  • Won a Competition
  • Contributed a Blog Post
  • Beta Tester
  • Bought between 50 and 99 items
+4 more
MSFX Volunteer moderator says

I think the whole search for the forums needs an overhaul IMO

381 posts Keep Walking
  • Has been a member for 3-4 years
  • Elite Author
  • Sold between 100 000 and 250 000 dollars
  • Bought between 100 and 499 items
  • Referred between 100 and 199 users
  • Exclusive Author
UXbarn says

I think the whole search for the forums needs an overhaul IMO

Agree. :)

by
by
by
by
by
by